Forum Update

NOTICE: There are NO PUBLIC FORUMS you can post to on this site. You must register to post and view additional forums. PLEASE READ THIS FORUM for general information about features of this forum, rules, member options and guidelines.
Post Reply
User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Forum Update

Post by LoneBear » Fri May 29, 2015 10:24 am

I've updated to the new release of phpBB. A few things work differently, and there are a lot more options available:
  • The theme is now responsive and able to support tablets, smartPhones, etc. with automatic resizing and reconfiguration.
  • Look under "Quick links" to get unread posts, active posts, etc.
  • I've installed a number of language packs that change the menus and navigation buttons into different languages. You can select these by clicking on your username, select "User Control Panel" and "Board Preferences."
  • Different time zones are fully supported, also selectable in the User Control Panel.
Please report any problems by reply here, or PM me.

Thanks.
4 8 15 16 23 42

User avatar
Djchrismac
Cellarius
Cellarius
Posts: 296
Joined: Thu Jun 20, 2013 11:05 am
Location: Glasgow, Scotland

Re: Forum Update

Post by Djchrismac » Fri May 29, 2015 12:55 pm

Nice one LB, I like the new forum design you have chosen, it works really well on mobile devices, the unread post animation is a nice feature and I love the new mountain top banner.

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Fri May 29, 2015 1:32 pm

Couple of quirky things, because I automated some features using the 'autogroups' module...

If you had access to the "Paths of the Ancients" forum and it's gone now, you need to make 25 posts to get access back (monastery members exempted). The software is enforcing this rule now and it won't let me just add people with less than 25 posts to the group for access (it deletes them minutes after I add them). So just find something to talk about!

If you had access to "Adult Psychology" (restricted to legal adults) and it disappeared, you need to enter your birthdate in your profile, as that is how autogroups is figuring out of you are of legal age. Set your birthdate and you should be immediately added back. If you did not have access (had to request it before), and are of legal age, you should see it now.
(lick: Username (top right), User Control Panel, Profile and set birth date.

I fixed the "Recent users" SQL query, so it should be displaying properly. I've also omitted the Bots from the listing.

(I'm trying to automate more features, as the maintenance is just taking up too much of my time, doing things manually.)
4 8 15 16 23 42

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Spammer registrations

Post by LoneBear » Fri May 29, 2015 4:50 pm

It appears the registration code block stopped working after the upgrade, and some spammers got in. I have deleted the accounts and changed the registration code.

The problem was related to my inclusion of different board languages (American English, British English, Finnish, French, Chinese, Spanish, Portuguese), which did not have the registration code question associated with the language. I've used Google translate to add the appropriate questions, so hopefully it is working again.

I will keep an eye on registrations for a few days.
4 8 15 16 23 42

User avatar
Lozion
Cellarius
Cellarius
Posts: 384
Joined: Sun Dec 01, 2013 4:55 pm
Location: Changes all the time..

Re: Forum Update

Post by Lozion » Sun May 31, 2015 9:51 pm

Great job
In rapport we thrive, in rivalry we strive.

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Thu Jun 11, 2015 8:25 pm

Fixed a bug in the upload/attachment system. Attachments should now upload and display properly.
4 8 15 16 23 42

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Thu Oct 20, 2016 12:10 pm

I'm working on fixing some styling problems concerning subscripts and superscripts, reported by animus. If the site display strangely, wait a minute and refresh the page. The software tends to cache page templates, so when you make a change it gets screwed up until I can clear the caches.
4 8 15 16 23 42

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Thu Oct 20, 2016 12:46 pm

Superscripts and subscripts should display correctly now. I updated some other theme parameters, so let me know if anything else broke.
4 8 15 16 23 42

User avatar
Djchrismac
Cellarius
Cellarius
Posts: 296
Joined: Thu Jun 20, 2013 11:05 am
Location: Glasgow, Scotland

Re: Forum Update

Post by Djchrismac » Thu Oct 27, 2016 2:43 am

LoneBear wrote:Superscripts and subscripts should display correctly now. I updated some other theme parameters, so let me know if anything else broke.
Font size on this and the RS2 forum is now massive for me, is anyone else getting the same? Guessing it's a result of the super/sub scripts fix?

Ilkka
Atriensis
Atriensis
Posts: 676
Joined: Fri Jul 26, 2013 3:17 am

Re: Forum Update

Post by Ilkka » Thu Oct 27, 2016 7:27 am

Djchrismac wrote:Font size on this and the RS2 forum is now massive for me, is anyone else getting the same?
Yep same here. I got big font size as well, not complaining though since I use TV as computer screen and it is about 1,5 meters away. No need to squint at least :)
Enjoy the Silence

User avatar
Andrew
Centurio
Centurio
Posts: 241
Joined: Fri Jun 17, 2016 9:53 am

Re: Forum Update

Post by Andrew » Thu Oct 27, 2016 9:39 am

Djchrismac wrote:
LoneBear wrote:Superscripts and subscripts should display correctly now. I updated some other theme parameters, so let me know if anything else broke.
Font size on this and the RS2 forum is now massive for me, is anyone else getting the same? Guessing it's a result of the super/sub scripts fix?
Yes, and with no option to zoom out, on mobile, it makes me feel claustrophobic.
"Classical historians traditionally dismiss tales of magic as unworthy of scholarly attention, but to us any mention of a witch's broomstick or wizard's wand evokes the smell of a scientist's laboratory." The Sphinx and the Megaliths

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Thu Oct 27, 2016 9:59 am

The font size is set to 1 em (1 standard line height), which is determined by your browser settings. Are you zoomed in already? Most browsers zoom with CTRL - (minus, make smaller), CTRL + (plus, make larger) and CTRL 0 (reset to default). Firefox also has a zoom in the menu drop-down on the top right (the three horizontal bar icon) and is set by Tools/Options/Content "default font."

I'll have to do some research to see how to adjust for phones.
4 8 15 16 23 42

User avatar
SiteAdmin
Gregralis
Gregralis
Posts: 2
Joined: Thu Jul 22, 2004 1:43 am
Location: Houston, Texas

Re: Forum Update

Post by SiteAdmin » Thu Oct 27, 2016 10:19 am

I have forced the font height down to 12 pixels, which should be close to the original size from the default theme. Apparently, they have had to come up with new scaling options for the tiny phone screens, but I have no way to test them, since I don't own one.

User avatar
Djchrismac
Cellarius
Cellarius
Posts: 296
Joined: Thu Jun 20, 2013 11:05 am
Location: Glasgow, Scotland

Re: Forum Update

Post by Djchrismac » Thu Oct 27, 2016 2:32 pm

SiteAdmin wrote:I have forced the font height down to 12 pixels, which should be close to the original size from the default theme. Apparently, they have had to come up with new scaling options for the tiny phone screens, but I have no way to test them, since I don't own one.
Nice one it's much easier on the eye now, cheers!

sovert
Indagator
Indagator
Posts: 25
Joined: Mon May 30, 2016 4:10 pm

Re: Forum Update

Post by sovert » Thu Oct 27, 2016 4:08 pm

Djchrismac wrote:
SiteAdmin wrote:I have forced the font height down to 12 pixels, which should be close to the original size from the default theme. Apparently, they have had to come up with new scaling options for the tiny phone screens, but I have no way to test them, since I don't own one.
Nice one it's much easier on the eye now, cheers!
Agreed, the larger font size was messing with my mobile, and inconvenient on desktop

User avatar
Lozion
Cellarius
Cellarius
Posts: 384
Joined: Sun Dec 01, 2013 4:55 pm
Location: Changes all the time..

Re: Forum Update

Post by Lozion » Thu Oct 27, 2016 8:08 pm

It went from huge on my iPad Mini v3 to close to what I was used to, so all good for me now..
In rapport we thrive, in rivalry we strive.

Ilkka
Atriensis
Atriensis
Posts: 676
Joined: Fri Jul 26, 2013 3:17 am

Re: Forum Update

Post by Ilkka » Fri Oct 28, 2016 8:44 am

Good here also, thanks.
Enjoy the Silence

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Update to phpbb3.2

Post by LoneBear » Tue Jan 31, 2017 2:16 pm

Another big update to the forum software. Testing it now; still some CSS issues to fix.

NOTE: after I upgrade, the forum may display in a screwed-up fashion (it did this in testing) because your browser is still using some old files from its local cache on your hard drive (same name, different content). To fix it, all you have to do is to refresh the page (normally, hit CTRL-F5).

The forum will be down for about 15 minutes when I do the upgrade, so if it is unavailable, just wait a bit and try again.
4 8 15 16 23 42

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Tue Jan 31, 2017 7:06 pm

The forum has been updated; I made some significant changes to the stylesheet to simplify things, so hoping it is still working OK. Tested the best I can, but I have a limited number of devices to test with.
4 8 15 16 23 42

User avatar
joeyv23
Atriensis
Atriensis
Posts: 663
Joined: Sat Apr 06, 2013 3:51 pm
Location: Salt Lake City, Utah
Contact:

Re: Forum Update

Post by joeyv23 » Tue Jan 31, 2017 7:58 pm

Things are a bit squirrely. There are a couple of drop down menus that are set on open. Some buttons are lit up in red, not sure if that is part of the update or not. Also, the forum index has spazzed out. I was able to work around them on the desktop, but it was even harder to navigate using mobile web.
Screenshot from 2017-01-31 18-55-39.png
Screenshot from 2017-01-31 18-57-27.png
Screenshot from 2017-01-31 19-01-25.png
"Living is not necessary, but navigation is." --Pompey
"Navigation is necessary in order to live." --Me

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Tue Jan 31, 2017 9:17 pm

joeyv23 wrote:
Tue Jan 31, 2017 7:58 pm
Things are a bit squirrely. There are a couple of drop down menus that are set on open. Some buttons are lit up in red, not sure if that is part of the update or not. Also, the forum index has spazzed out. I was able to work around them on the desktop, but it was even harder to navigate using mobile web.
You need to clear your browser cache. In Firefox: Options, Advanced, Cached Web Content, Clear Now button.

It will fix itself once the browser cache times out, but not sure how long that takes.
4 8 15 16 23 42

User avatar
LoneBear
Legatus Legionis
Legatus Legionis
Posts: 3695
Joined: Thu Jul 22, 2004 12:38 am
Location: Utah
Contact:

Re: Forum Update

Post by LoneBear » Sat Feb 11, 2017 5:33 pm

I had an old version of an extension that was causing some profile screens to show up blank. I have upgraded the extension, and the problem appears to have been fixed.
4 8 15 16 23 42

Post Reply